Inception stories can't be updated
Incident Report for WoodWing Software
Resolved
This incident has been resolved.
Posted over 1 year ago. Dec 31, 2015 - 13:16 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted over 1 year ago. Dec 31, 2015 - 09:37 UTC
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Dec 31, 2015 - 08:34 UTC