Degraded functionality for Swivle in US region.
Incident Report for WoodWing Software
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 20, 2018 - 18:48 UTC
Update
The S3 problems that were affecting Swivle seem to have been resolved by AWS.

Amazon is still investigating the issue. We continue to monitoring closely.
Posted about 1 year ago. Mar 20, 2018 - 16:24 UTC
Monitoring
Due to problems at Amazon S3 in the US-EAST-1 region, thumbnails, previews and originals cannot be viewed or downloaded. Also, uploading files to Swivle in US region is not working.

Amazon is investigating the issue. We are monitoring closely.
Posted about 1 year ago. Mar 20, 2018 - 15:46 UTC